How to Fix NS_ERROR_NET_INADEQUATE_SECURITY and ERR_SPDY_INADEQUATE_TRANSPORT_SECURITY in IIS on Windows Server 2016

If you've recently upgraded an IIS web server to Windows Server 2016, you may come across a NS_ERROR_NET_INADEQUATE_SECURITY error in Firefox or an ERR_SPDY_INADEQUATE_TRANSPORT_SECURITY error in Google Chrome. There are a few reasons for this and the main one is that IIS in Windows Server 2016 turns on HTTP/2 by default and only falls back [...]

HTTP/2, HTTPS, Let’s Encrypt, NGINX and WordPress Hardening

If you're running a Wordpress site on a Linux server running NGINX, then you might be interested in setting up a free SSL (HTTPS) certificate using Let's Encrypt. The internet is moving towards HTTPS, and even Google is said to rank HTTPS pages higher than the standard HTTP pages. If you're using Wordpress, you have [...]