Google Chrome Error SSL Server Probably Obsolete ERR_SSL_FALLBACK_BEYOND_MINIMUM_VERSION

If you're a Google Chrome user, you might have come across the Google Chrome Error SSL Server Probably Obsolete ERR_SSL_FALLBACK_BEYOND_MINIMUM_VERSION while trying to browse to a HTTPS website. Unfortunately, as a user, there's not much you can do to get around this error message except to try a different browser like Internet Explorer. About a [...]

This website uses cookies and third party services. Please view our Privacy Policy for more information. Accept